Adium

Profile: Jules Gravinese (WebVeteran)

AIM
Website http://www.webveteran.com/
Comment Count 39 comments
1 xtras

Latest comments

# by WebVeteran on 07/08/11 at 13:16:34

I do see the error myself. It will be a while until I can return to this project. In the meantime, use the previous stable version ( https://github.com/WebVeteran/Elegant-...pball/1.2.3 ) which seems to work.

# by WebVeteran on 03/28/11 at 13:20:25

User Icons: Perhaps. First I want to get 1.5f up to the same features as 1.2.3. I'm not too fond of user icons though. I may make it a variant instead.

Background: Yes I know. It was one of the features I disabled for 1.5a. I'm keeping it dark so it's more readable across any desktop.

# by WebVeteran on 03/21/11 at 15:12:08

Version 1.5a uses an updated javascript library (scripty2). I'm now using a completely custom slider mechanism and scroll wheel code. I'm pretty sure the scroll-to-bottom bug is fixed!
It's alpha because I had to remove some functionality for the major code change. I'll be adding it in over time. I plan on V1.5 Final having all the functionality from 1.2.3.
You can still get the latest full version (1.2.3) from GitHub: https://github.com/WebVeteran/Elegant-.../tree/1.2.3

# by WebVeteran on 03/07/11 at 00:05:51

Hi all. I've been very busy with work. Great for me and my family, not so much for Elegant Simple. But, from work that I learned quite a bit and will be folding that knowledge into Elegant Simple 2.5 which already underway! I'm removing LivePipe UI for the scroller, upgrading Prototype JS from 1.7 to 1.9, upgrading scriptaculous 1.8.3 to Scripty2 2.0b1, and using a completely custom scroller.
I'm hoping all this will remedy that pesky scroll-to-bottom bug. After that I'll circle back to the wishlist / requests.

# by WebVeteran on 12/06/10 at 14:19:37

I think I may have the scroll bug fixed. To reproduce the bug (using v1.2.2 which you can get at github: https://github.com/WebVeteran/Elegant-.../tree/1.2.2 ):
Send yourself many multi-line messages, so the window scrolls.
Scroll the window manually up and down. Leaving it partially up.
Send yourself a few small messages that won't wrap to a second line.
You should now see the bug.
Install v1.2.3 and repeat the process. You should not see the bug anymore. If you do, please note your versions (mine in parenthesis):
Mac OS (10.5.8)
Adium (1.4.1)
Safari (5.0.3 5533.19.4)

Fingers crossed!